Puntuado con 5 de 5 estrellas

please make it compatible with firefox 3.6

Esta valoración es de una versión anterior del complemento (1.5).