Works well with Firefox 2, but not compatible with Firefox 3 Puntuado con 2 de 5 estrellas

This extension works well with Firefox 2, but as of its version 1.1, it is not compatible with Firefox 3.