Puntuado con 3 de 5 estrellas

Looks good but there's no Firefox 3-3.5b4 support!