Puntuado con 5 de 5 estrellas

Great addon. It seems to work fine on FF 6.0a1 after changing the maxversion in install.rdf file.

Esta valoración es de una versión anterior del complemento (1.50.1-signed).