Puntuado con 4 de 5 estrellas

This is one of the most useful exetensions available for Firefox. Unfortunately, version 0.7.1 doesn't appear to work with Firefox version 5, even if you edit the install.rdf file.