Installation Problem Puntuado con 5 de 5 estrellas

Ad-block worked fined before, but I got a new Pc and am trying to install Ad-block but it says its not compatible with the "2.0.0.11" version of Firefox which I currently have. Please help, these ads are annoying : aamir_raza60@hotmail.com

Esta valoración es de una versión anterior del complemento (0.7.5.3).