Using the addon in TB 3.1.x Rated 5 out of 5 stars

Translation of jfmoyen's comment. The addon works now !!

In response to previous comments: it is perfectly possible to run this extension with Thunderbird 3.1.x, provided they modify a bit the file:

1. Rename the file in world_weather_etc.xpi ... . Zip
2. Open the zip, extract the install.rdf
3. Open install.rdf with a text editor
4. At line 50, in block <em:targetApplication> <! - Thunderbird -> change the maxVersion value and make it 3.1.9
5. It is probably also necessary, in line 9, change the version number (eg 2.4.1b).
6. Save install.rdf and the copy in the zip file to the palces of original install.rdf.
7. Re-register the zip file, rename it to xpi.
8. Install modified xpi file as a regular extension.