Rated 5 out of 5 stars

What a bunch of Cry-Babies! Most add-ons will not work with FF 3.0++ for at least 8-10 months down the road. Or when ever Mozilla starts helping these developers improve the current add-ons for FF 3.0++! It was made for FF 2.0, so stick with what works & Quit ur Bellyaching...
Para