Rated 5 out of 5 stars

Tuesday, April 21, 2009, 10:53:24 PM

Please Mr., Please! Update this fantastic add-on to work with FF 3.0++ or give it up to someone else that will do it. I miss it very much. Boohoo...