Rated 5 out of 5 stars

I was able to install version 1.5 into Thunderbird 6.0.1 today. Just extract the files, and modify the install.rdf file. I set the maxVersion to 7.0, and set the version to 1.5.W (for Wilbur!). Replace the install.rdf file in the .xpi package and install. Initial tests show it is working as expected!

This user has a previous review of this add-on.

Compatible with TB6

The extension is now marked as compatible with TB6.*, meaning all versions of TB6. You shouldn't have to do anything special.
Sadly, the new upgrade policies for TB are making it hard to keep up.