Rated 1 out of 5 stars

Doesn't work. Firefox 28.0

Useless, doesn't work Rated 1 out of 5 stars

Sorry, gave up trying, doesn't work. I uninstalled it.

Rated 1 out of 5 stars

uninstall!

Rated 1 out of 5 stars

Adware. Useless.

Absolutely useless!! Wasting my time with nonsense! Rated 1 out of 5 stars

Used to work a previously but now it's absolutely useless. At least for me it never seem to work as advertised. I live in a "foreign" country but prefer to browse the web using English. With this useless plugin activated most (if not all) websites that are language sensitive STILL display in the language from the country I browse from, not in English. Happily removed it today. This plugin is seriously NOT recommended by me. Thumbs down.

screw my profile: hands off! Rated 1 out of 5 stars

after uninstall I had to manually recreate my profile. *damn*

Rated 1 out of 5 stars

*bump* from reviews below..
"WARNING IT'S ADWARE! Rated 1 out of 5 stars

by Mark on March 12, 2013 · permalink

This ADD-ON contains aggresive Adware that displays Ads on other websites!
It seems that all ADD-ONS from this company are infected with Adware/Spyware.

P.s. The picture of the dev is just a stocksphoto that can be found on many other sites."

Doesn't seem to work here Rated 2 out of 5 stars

Been trying to use it on the version of Firefox that my employer bundled it into, but it does not seem to work from or to Japanese. I gave it more than the minimum star because the bottom option is a shortcut to the place where the language can be changed, but the suggested donation seems ridiculous, even if it did work properly.

Spyware in addon. Rated 1 out of 5 stars

Spyware in addon.

Thank you Rated 5 out of 5 stars

Version 1.7.8.5 is the best one, multilingual search technique.

Rated 1 out of 5 stars

Used to like it, but the sneaky new adware added by the new developer is disconcerting.

Don't install the newer version! Rated 1 out of 5 stars

It's a pitty for Firefox security, I had to confirm this extension contains now a bloatware! Somebody to fork so as to retrieve the past version ???

BEWARE contains Adware Rated 1 out of 5 stars

CONTAINS ADWARE

WARNING IT'S ADWARE! Rated 1 out of 5 stars

This ADD-ON contains aggresive Adware that displays Ads on other websites!
It seems that all ADD-ONS from this company are infected with Adware/Spyware.

P.s. The picture of the dev is just a stocksphoto that can be found on many other sites.

Oh, boy... Rated 2 out of 5 stars

First, note that other user has taken recently the ownership of this add-on, as the original developer, Captain Caveman, left the support and development for all his add-ons a few months ago. He offered his work to those interested.

And now we see the first related news. As Dillanski mentioned, be aware: the recent updates (since 1.7.8.5... but it's still harmless; 1.7.8.6+ are ugly) only adds a new option, *enabled by default*, for to integrate a "price comparison (WizeShoppy)". First time that I hear about it, but only by the source code added for its integration, I see that it works in a very intrusive way over all your web navigation, and, in general, I recommend stay away of things as this.

1.7.8.6 is still in a "waiting aproval by some AMO reviewer" state, so users (yet) didn't received this update.

Independently of the choices of the new developers for to monetize this add-on, not having a single mention of it in the release notes, is a fishy behaviour (EDIT 20/3: Now it's mentioned). And it seems that with other add-ons she(?) is doing the same.

Beware - it's sneaky AdWare!!!! Rated 1 out of 5 stars

If I could give Quick Locale Switcher ZERO stars I would. If you don't believe me that this add-on installs nasty ADWARE on to your computer just read their Privacy Policy. Click the link right beside the install button. They disclose the adware in the privacy policy. It's called WizeShoppy and it's nasty stuff. You've been warned.

Rated 5 out of 5 stars

thank you for this! i actually went and installed version 4 of firefox to be able to use this~

This review is for a previous version of the add-on (1.7.8.3). 

Not working anymore Rated 3 out of 5 stars

Looved this addon, but it seems not to work anymore… (FX 16.0.2 on Ubuntu)

This review is for a previous version of the add-on (1.7.8.3). 

Rated 3 out of 5 stars

As of 8/25/12, the developer announced he is looking for someone to adopt his add-ons, and will not be doing any upkeep. I found the announcement on the support site.

This review is for a previous version of the add-on (1.7.8). 

Rated 5 out of 5 stars

Excellent plugin. Was able to resolve an issue in no time. Thanks much !

This review is for a previous version of the add-on (1.7.8).