1.2.1.1 Crashes Pale Moon Rated 5 out of 5 stars

I love this add-on and have been using 1.2.1 for a long time. However, trying to update to 1.2.1.1 crashes Pale Moon instantly! I've tried this on a 64-bit machine running Win 7, another Win 7 32-bit computer, and another on XP, all with the same results. Seems to work fine on Firefox. ??? 5 stars for the previous version.

UPDATE: The problem evidently had something to do with improperly signed extensions and extension updates from Mozilla. A new 25.3.2 Pale Moon "emergency update" is supposed to fix the problem, though I no longer see 1.2.1.1 on the site. :)

This review is for a previous version of the add-on (1.2.1.1-signed).  This user has a previous review of this add-on.

Developers did not update their add-ons. Signing process was performed by Mozilla automatically, but got reverted later because of some problems with older Fx builds.

https://bugzilla.mozilla.org/show_bug.cgi?id=1158467