Thunderbird 7.0 Rated 5 out of 5 stars

Thunderbird 7.0 was just downloaded to my laptop, and it says it's not compatible. Will you be correcting this? I miss it already.

This review is for a previous version of the add-on (3.32).  This user has other reviews of this add-on.

Thunderbird 7.0

The problem is that with such a rythm in the publication of new TB versions, it's hard to follow them. More, when I finish an update, I need to publish it on Mozilla's addon. Before becoming official, the theme needs to be reviewed. All themes, all extensions need to be reviewed if something is modified, in particular the TB version. So reviewers have a lot of work and it takes some time. They do correctly their job, but this new rythm is totally fool. More, I think that with such a policy, Mozilla is killing theme and extension development. I can't simply follow. I have a real life, I do this work for my pleasure, but here it's too much. I'll probably publish an update, but you can be sure that when it is ready, it will be already outdated !