Incompatable with FF 18 Rated 1 out of 5 stars

Won'r install. Firefox 18 says it's not compatable.

In fact, ... this is the second time I've tried to install TB to replace WLM and the second time I just ran into an insoluable mess.

Never again!

This review is for a previous version of the add-on (2.8.0.1). 

You must install it in Thunderbird, not in Firefox, please read this:
http://kb.mozillazine.org/Extensions_%28Thunderbird%29#Installation