Not compatible with latest firefox Rated 1 out of 5 stars

I love this app and use it a lot but cannot install on the latest version of thunderbird as its incompatible with latest version of firefox!

This review is for a previous version of the add-on (1.2). 

Enigmail won't install in Firefox because it is a Thunderbird add-on. Please use "Save as ..." and save the file locally. Then launch the Add-on-Manager in Thunderbird and install the downloaded file.