Got it to work on TB 5.0 Rated 5 out of 5 stars

Second time writing this... first got lost somehow... so this will be shorter...

XPI files are ZIP files. Unzip and modify the file install.rdf so that the max version is set to 5.0 --- should read: em:maxVersion="5.0".
Replace the install.rdf file in the zip file and rename it back to .xpi
Install and enjoy!

NOTE: Please don't hold me responsible if this causes you issues. It works great on mine so I wanted to share until David releases a new revision.

This review is for a previous version of the add-on (0.0.2). 

Close tab on ESC 0.3 released

The new version, compatible with TB 5, has just been successfully reviewed and is available for download now!