Astara

About me

Developer Information
Name Astara
Location California, USA
Occupation Mad^h^h^hComputer Scientist
User since March 5, 2007
Number of add-ons developed 0 add-ons
Average rating of developer's add-ons Not yet rated

In a little more detail...

Been a FF user since before it was FF -- going back to to 1.0 (or possibly pre, since worked at sgi where we were early adopters of such tech)...

My Reviews

Hide Caption Titlebar Plus

No longer works Rated 2 out of 5 stars

It's likely a compat issue with my extensions & browser ver (3.6.28+).. but I have 2 bars at top, the transparent location/menubar (all in 1 bar), and the win7 transparent caption bar above that.

When I install this extension, I get a half-height opaque title bar. :-( It may be half a bar less space, but its darn uglier.

Of course I will admit to be a bit strange -- like setting my background IN THE BROWSER to transparent...
and having web content display on my desktop...

Problem with that was it was hard to move the 'window' around and resize it..(not impossible, just hard)... AND ... I usually have a variable background pic and depending on the pic it either worked very well, or it was pretty unreadable.

If only I could get an opposite color fringe around the lettering or a shadow, like the desktop does on it's text. Then it would always be readable.

Here's a pic of my extensions page:

The green part was my desktop... an old foxgirl logo was my 'about blank' background..so the extensions page plotted on top of an about blank... rather confusing...

http://imageshack.us/a/img14/9225/ffgoneinvis2.jpg

But if I had this extension installed, I would have had a half-height opaque bar at the top of the browser -- delineating it -- which, in that particular situation might not have been a bad thing... But barring such extremes, when I want the at least the edges to be transparent, having it come up opaque was a bummer.

Can' you apply the mini window function buttons to the stop of the highest toolbar (in my case would be the menu bar (which doubles as my location bar) -- menu is hidden away in 'personal menu'...(the extension)..

Was neat when it used to work...sigh.

P.S. Please let the user decide on an icon for the menu -- like personal menu -- nice and unobtrusive rather than a 1 orange-fits all, jarring color...good for getting attention, but you don't always want attention on the menubar....

P.P.S. why is this review flagged for review? weird.

This review is for a previous version of the add-on (2.6.0). 

Autotrans Reloaded

Rated 4 out of 5 stars

Hasn't the client had to send a X-session-id back to the server for the conversation to continue:
I get this back:
409: Conflict

Your request had an invalid session-id header.

To fix this, follow these steps:

1. When reading a response, get its X-Transmission-Session-Id header and remember it
2. Add the updated header to your outgoing requests
3. When you get this 409 error message, resend your request with the updated header

This requirement has been added to help prevent CSRF attacks.

X-Transmission-Session-Id: <long alpha-numeric string>

Wonder what I messed up w/on my setting...
sigh...
It used to work well!... so will rate it a 4 now...
(still works on 3.2.28 ...)

Policy Manager

Could be more convenient... Rated 4 out of 5 stars

very powerful way of fine tweaking permissions, BUT the permissions you want to tweak are hidden!!! You have to already know what you want to tweak....(or...patch <Firefox>/chrome/toolkit/content/global/config.js:
--- config.js 2011-12-07 04:24:12.476588800 -0800
+++ config.js.orig 2011-11-03 07:26:30.000000000 -0700
@@ -191,6 +191,8 @@
if (topic != "nsPref:changed")
return;

+ if (/^capability\./.test(prefName)) // avoid displaying "private" preferences
+ return;

var index = gPrefArray.length;
if (prefName in gPrefHash) {
@@ -299,6 +301,8 @@
for (var i = 0; i < prefCount.value; ++i)
{
var prefName = prefArray[i];
+ if (/^capability\./.test(prefName)) // avoid displaying "private" preferences
+ continue;

fetchPref(prefName, gPrefArray.length);
}
---
Of course if you patch it and screw yourself, you might need to reinstall and get do a new profile... (backups are good)...

You can have it interfere w/noscript...But it seems you have to set the top level default policies to be the same as 'no scripts', or no script will think it is 'uncovered'...

I.e. no script sets default policies a certain way, and this does too -- if they don't agree, no script doesn't know what is going on...

This could use a menu of all caps and policies that are settable -- rather than having users root around in their firefox source code...not too many users are likely keen on that.

FireICE

Rated 5 out of 5 stars

I virtually never hit sites affected by this, BUT, had to install it, with the good recommendation from NBC:
https://wiki.mozilla.org/Legal/Infringement_Notices/NBCUniversal
----
I figured it had to be the right thing to do...

Thanks NBC for the head's up...

(idiot ICE -- China's censors in the US!)

Imgbox.cc - Host images with right click.Pay upto $ 3 for every 1000 uniques views.

Rated 1 out of 5 stars

I don't this would work well considering the website it refers to is listed as 'for sale'....

Color That Site!

this extension going away? Rated 3 out of 5 stars

Tried it on a site, got an error .. saying it couldn't access http://www.colourtablepopup0k0_2,0,0,2.com/
============================================================================================================
Weird. Guessing it tried to call a javascript function but it got interpreted as a website?
============================================================================================================
Tried to goto home page and got take to a google groups page that says:
============================================================================================================
Color That Site!

============================================================================================================
Home
Discussions
About this group
Join this group
View this group in the new Google Groups
============================================================================================================
Group info
Members: 7
Language: German
Group categories: Not categorized
More group info »
============================================================================================================
Home

============================================================================================================
Zipped versions of the pages and files associated with this group will be available for download until August 31, 2011. After this date, this feature and the zip file downloads will be turned off permanently. Download pages | Download Files
============================================================================================================
Doesn't look good...

This review is for a previous version of the add-on (0.13). 

Stylish-Custom

Rated 3 out of 5 stars

I just edited the rdf, put max version for stylish in at 1.*, -- figure when it breaks it breaks.

anyway, working now.

Easy Google Translate - NOW TALKING!!!

doesn't work well on windows (takes over CTL key) Rated 1 out of 5 stars

Well Crappy FF review system -- I don't believe this.
<br>
It stored my '*' rating, but left off the review! (will rewrite )....
<br>

(also seems to be running all the lines together)
<br> so putting tags where breaks should be, (just use your 'mental HTML processors to see this post as it was intended! ;-)
^ BTW, there ARE line breaks either before or after every tag (in the compose window)...so if they don't show up, you'll know why)

<br>
<p>
well, .. problem is, that with this extension installed, whenever I pressed CTL-A or CTL-S, A popup came up on my screen saying I had to set a language to translate from/to! I didn't even know where the popup was coming from or where to set the language -- but more importantly, I DIDN'T want to translate text, I just wanted to select text and copy it to my 'copy buffer'... which I coudln't do with the keyboard with this extension installed. (had to use mouse options).
</p><p>
If you want to use a hotkey -- let the user select their own choice/combo!
</p><p>
Taking over their CTL key is bad design for windows users!
</p>

This review is for a previous version of the add-on (2.2). 

Firebug Autocompleter

Addon Requires Additional Items Rated 2 out of 5 stars

w/FF 3.6.18, & Fbug 1.7.3, this addon is self-disabled with an error:REQUIRES ADDITIONAL ITEMS...no hint as to what other items are needed...:-(

p.s. I would have give this 'no rating', since I don't feel I should have to give a rating for something
that I can't get to work in the first place that may be no fault of the addon...

This review is for a previous version of the add-on (1.3.1). 

AeroBuddy

Nice looking, with limitations Rated 4 out of 5 stars

It looks really nice if you can get a set of extensions to work with it (not super hard, just some common ones might not work well). Also has an annoying jitter on the tab bar when it gets over 10-20 tabs - seems to be an even number...tab will jitter using 100% cpu -- neet to open a tab window to stop the jitter or you can't resize the window. Also some text is unreadable at times -- like when black text is on transparent surrounding over dark background or vice-versa (light on light)....always something.
I hope they fix the bugs and provide some more fine tuned 'protection' for text against same-shade background...that and the jitter are two that may make me eventually uninstall this *very* attractive extension!
(right now I have all sections turned on ... but that is when it looks the best!)

Secrets of Firefox

question Rated 3 out of 5 stars

What features/secrets does it enable?

Before I install it I'd like to know if I WANT them! :-)

(i.e. -- new feature: show all text in pig-latin: NOT!)

This review is for a previous version of the add-on (1.1). 

rikaichan

1.09 is missing; use 1.08 to install something Rated 3 out of 5 stars

Version 1.09 is corrupt. Use version 1.08 -- it installs.

This review is for a previous version of the add-on (1.09). 

Boox

Rated 2 out of 5 stars

This extension isn't what it claims it is.

It claims to be something to enhance bookmarks. That's very little of what it does -- it does provide popups while browsing your bookmarks, that show extended information you would normally only see in the bookmarks organizer. Some may find this useful, but I never look at that info anyway -- I just use them.

Everything else is for RSS feeds. "Live Bookmarks". It has stylesheets for that among other features -- all things that ONLY work with Live bookmarks -- features that don't work with regular bookmarks.

As a result of the false advertising, I only give this tool a 2 out 5 stars, 1 star because it appears to 'work' insomuch as it's documented to do (after you explore the functionality) and it doesn't seem to crash or corrupt things. Second star is for usefulness of popup descriptions of bookmarks -- something that should be builtin to the browser, but it isn't, so kudos for bringing FF up closer to minimum standards in this area. But that's it. I don't use RSS, so the rest is useless to me. If it was more useful as a bookmark tool set as it claims to be (and not focused on RSS) it might have gotten more stars from me.


This review is for a previous version of the add-on (2.5). 

AFOM - Memory Recovery & Retention For Firefox Only

Rated 1 out of 5 stars

Why does your extension say something about installing in "Documents and Settings?" That dir doesn't exist on my system nor on Win7 systems.

It's Not hard coded into Windows and can be changed (my user dirs are under "C:\home".

Also why does it say something about creating a entry under 'All Users'? I only want this extension to apply to my account. I don't want to affect all accounts on my system....

Is this a problem?

I tried to follow the link to the author's home page, but the ability to comment or ask questions there is disabled. (typed in comments and they just 'disappeared) -- first tried preview then post, but neither seemed to work....

I wonder if this extension hardcodes all these aging pathnames...

Vimperator

ok...but..on/off please? Rated 4 out of 5 stars

It looks interesting, but is overwhelming for a new user of the interface (though I am fairly handy with vi/vim/gvim, though not arcana),
BUT, it would be alot more usable if it had an off/on switch other than uninstall/install, like other tools that allow one to turn it on or off.

To get any work done I had to uninstall it.

I _am_ retrying it...but if I have to uninstall it too many times (disabling it didn't fix anything -- had to resort to firefox safety mode), I won't bother...it's too hard resetting my settings.

This review is for a previous version of the add-on (2.1). 

Remove Duplicate Messages

Rated 1 out of 5 stars

Do not install this unsupported extension.
The author has abandoned it and left it as a copyrighted (unable to be taken over by anyone else) project -- it has noticeable and severe limitations (though it still works), but you will regret using it.

Try the 'alternate' Remove messages - a (forced) rewrite from scratch because this one was copyrighted, that was published under an open license and is being maintained and extended -- this one took me *hours* to process duplicates in a tiny window...

It really should be removed as no-longer maintained.. (and a closed-source license -- even though you can look at the source).

This review is for a previous version of the add-on (0.1.06). 

AnyColor

5 * for idea; implementation?: No rating (N/R). (Not same as bad rating). Rated 5 out of 5 stars

This does not bode well:
Firefox could not install the file at

https://addons.mozilla.org/en-US/firefox/downloads/file/33629/anycolor-0.2.0-fx-win.xpi

because: Invalid file hash (possible download corruption)
-261

This review is for a previous version of the add-on (0.2.0). 

AnyColor

5 * for idea; implementation?: No rating (N/R). (Not same as bad rating). Rated 5 out of 5 stars

This does not bode well:
Firefox could not install the file at

https://addons.mozilla.org/en-US/firefox/downloads/file/33629/anycolor-0.2.0-fx-win.xpi

because: Invalid file hash (possible download corruption)
-261

This review is for a previous version of the add-on (0.2.0). 

Window Resizer

Rated 3 out of 5 stars

Does it reset or set the javascript.screen size? Some sites look at the screen-size and size their content based on the screen\'s size -- and not the window\'s size, so if this tool doesn\'t resize screen variables (so it can report to a website that the user is sitting on an 800x600 screen). It\'s a real pain, since you want to resize your window for a site to look right -- but you can\'t do anything other than what they decide for your screen size. Grrr.\r\n

This review is for a previous version of the add-on (0.5.1).