Working version for FF4/5 Rated 5 out of 5 stars

I had the same problem starting with Firefox 5.

The problem arises from the missing "chrome.manifest" - I created one, increased the version to 0.5.5 and set it to be compatible with up to Firefox 5.*:

Original/English version:
German version: (thanks to

THANKS to Jeremy!