Installation Problem Rated 1 out of 5 stars

I am getting continuous mismatched domain messages, so I tried installing, it says it can not install because I have Firefox 3.0, supposedly I don't need it because I have Firefox 3.0 but I still get the messages so it looks like I do need it but I can't install it, sounds like a catch 22