installing in Thunderbird 2.x while using FF 3 Rated 5 out of 5 stars

If you got to this add-on via the "Firefox Add-ons" page and you're using Firefox 3, it won't let you install it. Instead, go to the Thunderbird Add-ons page at https://addons.mozilla.org/en-US/thunderbird/addon/2131 and follow the directions there.

Great add-on, highly recommended for email accounts that consistently don't have correct (or up to date) security certificates.