Rated 1 out of 5 stars

It still doesn't work. Just did a fresh install of FF 4.0.1 on my home machine and it still says that it's not compatible with 4.0.1. How did you get it to work? Did you install the add-on on 4.0.1 or on 4.0 and upgraded FF later on?

This user has other reviews of this add-on.