Compatibility Issues Rated 3 out of 5 stars

I could really benefit from this add-on, please make it compatible with firefox 3.0. I am unable to install it cause of the version issue.

This review is for a previous version of the add-on (0.1.2.1).