Won't install Rated 1 out of 5 stars

According to the page on Addons for Firefox, version 1.8 covers 3.6a1,
but it won't install & I get an error msg that says it's "not compatible with Namoroka 3.6a1."

This review is for a previous version of the add-on (1.8).