Not Compatible anymore Rated 3 out of 5 stars

This add on just great to view ones feeds but alas does not work with Firefox 4 I installed today. Please could you make this compatible with this aversion. :)

This review is for a previous version of the add-on (1.0.5). 

newest version compatible

The newest version is always at http://newsfox.mozdev.org/installation.html#newest.

Right now you can also get the newest version from the all downloads page here.