Still works in Tb5 Rated 5 out of 5 stars

I just upped the maxVersion in the rdf to 6.0.0**. (I also created a new 18x18 button image using the new Fx/Tb "standard"--looks better... one size fits all. :D)

**The simpler way nowadays is to just install Add-on Compatibility Reporter (which, primarily, disables checking for compatibility).