Rated 4 out of 5 stars

Excellent add-on. There is however a serious error with Firefox: the newest version 1.5 cannot be installed. An error message appears: Ffox could not install this file, because not a valid install package -207. As I see it, this is not an error of the developer but of Ffox itself, so please correct it as soon as possible. Similar errors have existed several times before, as well.

This review is for a previous version of the add-on (1.5).