For anyone that cannot use this addons on firefox 57, change your browser to firefox ESR Rated 5 out of 5 stars

For anyone that cannot use this addons on firefox 57, change your browser to firefox ESR and you still continue using this wonderful addons.

This review is for a previous version of the add-on (1.28.2).