Please, need be compatible with version 57 Rated 3 out of 5 stars

Please, need be compatible with version 57

This review is for a previous version of the add-on (1.25). 

FF56 will be the last version this addon compatible with, because mozilla is killing all extensions that require XUL.
https://blog.mozilla.org/addons/2016/11/23/add-ons-in-2017/comment-page-1/
For now MP+ still runs fine in FF57 (you need adjust max version in install.rdf and disable xpinstall.signatures.required in about:config), but it will most probably change in the future and nothing I can do about it.

[EDIT]
It's no longer compatible with FF57 and never will, give all the thanks to mozilla for that.