SeaMonkey 2.4 Rated 3 out of 5 stars

Working on compatibility with SeaMonkey 2.3 and 2.4 ?

This review is for a previous version of the add-on (1.2.12).