Rated 5 out of 5 stars

For people complaining after the v17 upgrade, be sure to upgrade you "Google agenda provider" plugin too. The problem comes from it (you need version 0.18 of the google provider plugin).

This review is for a previous version of the add-on (1.9).