Rated 5 out of 5 stars

Hope this will always stay up todate.

I suggest to install "Lightning Nightly Updater (Unofficial)" and update the plug-in using that.
That way I can get the plugin working even with Thunderbird 3.0b2

This review is for a previous version of the add-on (0.9).