Not for 4.0 final Rated 4 out of 5 stars

Okay it's complicated, buggy and feels like it gets broken by every release of Firefox, but it's very full featured. Be aware that doesn't work on 4.0 final release despite being listed as compatible here. See https://bugzilla.mozilla.org/show_bug.cgi?id=642182

This review is for a previous version of the add-on (