Navigator 9 Compatible! Rated 5 out of 5 stars

Unlike IE View (std.), IE View Lite will install on Netscape Navigator 9 (i.e. the "new one").

For those of you who prefer the real Application to the IE Tab option, this is your answer for Navigator 9!

Rock n roll, mr/ms developer person sir / ma'am!

This review is for a previous version of the add-on (1.3).