Sad news! Rated 1 out of 5 stars

Just tried to manually change the version number in the install.rdf of the outdated ietab-1.5.20081203-addons.xpi to maxVersion "3.6.*" but to no avail. It did install without error message, but unfortunately wouldn't work.

This great add-on really needs updating. Would you? Please!

This review is for a previous version of the add-on (1.5.20090525).