Rated 1 out of 5 stars

WAY WAY WAY over-complex. I just want simple SIMPLE management of proxy switching. There were so many great little apps to do this but now the only proxy manager the new versions of FF accepts is this godawful thing. It's completely incomprehensible. I can't get a little quick-switch button on the toolbar. I have a master's degree in computer science and I've been working in IT for over 25 years -- AND I CANNOT MAKE THIS THING WORK. Please give us a stripped-down version that just does simple, straightforward proxy-switching without all the crazy baked in.

This review is for a previous version of the add-on (6.1.9). 

FoxyProxy Basic

Use FoxyProxy Basic instead.

Rated 5 out of 5 stars

good

This review is for a previous version of the add-on (6.1.9). 

Rated 5 out of 5 stars

Great features, works amazingly well. If you have to deal with switching proxies for any purpose, this is definitely the tool I would recommend.

This review is for a previous version of the add-on (6.1.9). 

Rated 3 out of 5 stars

Not sure what to say. I'll have to say, because of the new firefox forced changes on foxyproxy, it has now become unusable for me, even since the new version before FF 57 rolled out. I had to revert to the old version to make it work when I was still using FF 56 and earlier versions. Now with FF 57, there doesn't seem to be a way to revert to earlier versions, then the current foxyproxy no longer works, even though all the proxy and patterns look the same as before.

Downthemall and flashgot and a few other important add-ons also become invalid. I guess it is time for me to abandon Firefox for good finally, despite that I have been using it (and its predecessor) for the past 20 years.

This review is for a previous version of the add-on (6.1.9). 

FoxyProxy 4.6.5

If you decide to stay with FIrefox 57, you get the last version of FoxyProxy that works with it, 4.6.5, from here :
https://addons.mozilla.org/en-US/firefox/addon/foxyproxy-standard/versions/?page=1#version-4.6.5

Rated 5 out of 5 stars

FoxyProxy is an indispensable extension for me. In fact I waited until FoxyProxy was available that I made my final decision to upgrade to Firefox 57. I'm grateful that FoxyProxy is live and going strong with every new release on Firefox Quantum. Thank you FoxyProxy developer!

This review is for a previous version of the add-on (6.1.9). 

Rated 5 out of 5 stars

Not as good as the previous version, but it still works as intended and the dev is working hard to make it better. Would recommend.

This review is for a previous version of the add-on (6.1.9). 

Rated 5 out of 5 stars

powerful and easy to use

This review is for a previous version of the add-on (6.1.8).  This user has a previous review of this add-on.

Rated 5 out of 5 stars

難得的好工具,感謝開發者!

This review is for a previous version of the add-on (6.1.7). 

Rated 5 out of 5 stars

I've been using it for a very long time and it really rocks. Like many on updating to the new 57+ webextension version of the addon I was pretty annoyed as it didn't do what I was needing but I read your post and understood your pain & downgraded the extension. I truly appreciate the quick work you've done to make this addon work the same way as the old one, I went to firefox 57 today, and honestly it does everything I need and whilst I find the addon looks a bit cheesy and the UI could do with a bit of love, it works really well once configured and at the end of the day that's what I care about :)

P.S. can you bring back the spinning logo based on the color of the matched proxy?

This review is for a previous version of the add-on (6.1.7). 

Thanks

Thank for the compliments. The UI will evolve and get better over time. The spinning logo is not possible in Firefox 57, due to this Firefox bug: https://bugzilla.mozilla.org/show_bug.cgi?id=1406473
But I will at least provide the ability to change the icon or overlay different text on the icon based on the matched proxy. Thanks for your patience.

Rated 3 out of 5 stars

Where is the "pattern subscription"?
(e.g. how to use gfwlist)

This review is for a previous version of the add-on (6.1.7). 

Coming soon

Hello, it will return soon as I add more features to the addon. Rewriting 10 years of code in 3 months meant some features did not make it right away.

great work,but need some improved Rated 4 out of 5 stars

the distance of proxy entry menu list is too close,need expand some space,click proxy meny item need careful.

This review is for a previous version of the add-on (6.1.7). 

Will fix

OK, I will fix in next release. Thanks for reporting the problem.

Rated 5 out of 5 stars

I would like to thanks the developer behind this extension, for the great work he has done migrating it to be usable under firefox quantum. Good work!

This review is for a previous version of the add-on (6.1.7).  This user has a previous review of this add-on.

Thank you, Victor!

Rated 5 out of 5 stars

good word

This review is for a previous version of the add-on (6.1.7). 

Rated 5 out of 5 stars

Really appreciate the effort you put in to port foxyProxy to the new Firefox version.
However there is one little remark concerning the UI. Could you make it so that I can also click on the text in the UI and not only on the buttons/icons? Because it's confusing and annoying sometimes.

This review is for a previous version of the add-on (6.1.7). 

yes

Working on it.

Rated 5 out of 5 stars

when I imoprt my old pattern and want to add new one, the new-button doesn't work.

This review is for a previous version of the add-on (6.1.7). 

Many patterns?

UPDATE: fixed in 6.1.8
Hi, do you have many, many patterns? If so, it is known bug and new release is coming today with a fix.

Rated 5 out of 5 stars

Still the best proxy tool IMO !!! Thanks Eric for such a great tool

This review is for a previous version of the add-on (6.1.7). 

Thank you

Thanks for taking the time to create an account at addons.mozilla.org and to write to me. I appreciate it!

Rated 3 out of 5 stars

After I imported my old FoxyProxy configuration (with whole gfw patterns), my FF57 just stuck.
When I restarted FF57, it ate up all the memory, and then it crashed.

After removing FoxyProxy, the problem disappeared.

This review is for a previous version of the add-on (6.1.7). 

Upgrade to 6.1.7

Fixed in 6.1.7. sorry for the trouble.

Rated 5 out of 5 stars

Thanks for upgrading it for FF57. It has a smaller feature set now but I guess it cannot be helped with the new addon API.

This review is for a previous version of the add-on (6.1.3). 

More coming

We will be adding more features soon (context menus, quick add, clear cache&cookies on proxy switch). But it will take some time.

Rated 5 out of 5 stars

When can this new ff57 edition import proxy files like gfw-list?
Manual input patterns is horrible.
Thanks.

This review is for a previous version of the add-on (6.1.3). 

Rated 5 out of 5 stars

Developer fixed everything in record time. Recommend.

This review is for a previous version of the add-on (6.1.3).  This user has a previous review of this add-on.