Needs improvements Rated 4 out of 5 stars

What I wrote below still applies at some degree, but the response from Piro makes a good point.
The old version was limiting the functionality. If the code was "spaghetti" then the logical option was to throw it away, action often done in software development and mentioned in some programming methodologies.
Anyway... one important thing I appreciate in this moment is that the project is still active. Developers care... so the future seems good :)

-----------------------------------------

I've used this addon in the past (see version 0.6 with firefox 3) and it was really really great. I used to do alot of work with it. My productivity increased dramatically. Easy to use with lots of functionality. In a word... genius.
But now the splitting is done using windows. So for every split you will have a new window.
This means that space will be wasted (windows usually have borders). Excessively more bugs were introduced because of the functionality being moved outside Firefox (because window functionality is not really a firefox thing, but a OS one)

Why developers didn't kept the old style, splitting in the same window. Clean, effective, almost bug free. Even now you can use an old version (0.6) with compatibility mode disabled from within your browser (version 6 for me). You will see that much of the addon still works and yeah... the splitting works.
So why throw away the good...? Just make version 0.6 compatible with firefox 6 and throw away version 2+ of this addon...

> Why developers didn't kept the old style, splitting in the same window. Clean, effective, almost bug free.

It is not true. Even if you thought that the old version was really bug-free, actually it was founded on many sacrifices - in other words, I had to spend much time to maintain it in old days. To keep it compatible to very frequently updated Firefoxes in the future, more sacrifices will be required. I cannot maintain such a spaghetti-sucks-fuckin' codes anymore.

If you think that I'm lying and it is very easy to do it that keeping the old Fox Splitter compatible to future versions of Firefox, then you should fork the old Fox Splitter 0.6 from my github repository.