Be Sure That You Have the Most Updated Version of GNUPG... Rated 5 out of 5 stars

Previously I stated that Enigmail doesn't work at all as an add-in with T'bird 2.0.X. A premature statement on my part: Enigmail works fine as long as you have installed a current version of GNUPG (that would be version 1.4.7 or later) I was originally using GNU 1.4.6, which would not generate a keypair with Engmail 0.95.6. Once you have the updated version of GNUPG, Enigmail will work just fine with T'bird 2.0.X.

My sincere apologies for jumping the gun the first time.

This review is for a previous version of the add-on (0.95.6).