Great but doesn't currently work Rated 5 out of 5 stars

Some installs of 1.3.3 will fail on 8.0. This is a Patrick vs Mozilla issue as far as I can tell. I.e. Patrick says it's Mozilla's fault and if I could find a Mozilla comment it would probably point the other way.
ON the plus side I've used this thing for years and if extension installation processes are reformed and I can start using it again I happily will.

This review is for a previous version of the add-on (1.3.3).