"Incompatible with FF5" and above Rated 1 out of 5 stars

I just upgraded to FF5 and this add-in "Duplicate This Tab" was flagged as not compatible and was disabled. As per other user's suggestion I looked at Add-on Compatibility Reporter but since it is "Recommended for alpha and beta users only!" I decided not to use it as I'm not in that arena for my browser. At this point I will be evaluating other tab duplicators or consider switching back to MSIE which has native tab duplication capability.

This review is for a previous version of the add-on (1.2). 

Rated 1 out of 5 stars

I've been using this add in since FF 3.x and love it. Unfortunately the author has not updated it for FF5 or FF6 beta. I have contacted him several times but not had any answer. It seems he is no longer supporting this add in. Suggest you choose another add in that has ongoing support.

When FF4 came out the author delayed updating the add in for several months so it was not compatible with FF4 for a while. Eventually he did update it after I emailed him several times.

This review is for a previous version of the add-on (1.2).