Rated 4 out of 5 stars

Pretty neat theme. I actually installed this on Firefox 7 alpha (nightly channel) and it seems to work just fine! so @paulpostma you can install this addon and upgrade to newer firefox and you should be fine. You may need Addon Compatibility Reporter however to use this out-dated version but it works fine.