1.6.1 is the last working version for PaleMoon Rated 3 out of 5 stars

This one really needs a forked version for people who refuse to engage in the Australis stupidity. If you run PM you need version 1.6.1 and then refuse to update it.