Rated 5 out of 5 stars

Doesn't work since FF update to 21, please fix this much needed addon. Edit: The 2.3.2 Beta 15 that is available on their website seems to work ok.

This review is for a previous version of the add-on (2.3.1).