Rated 5 out of 5 stars

For those desperate to make this work in FF8, it is possible to edit the <em:maxVersion>6.*</em:maxVersion> field in the install.rdf file and change the 6 to 8 (or higher). It's not recommended - you need to know what you are doing and if you mess up you could bork Firefox - but YSlow seems to work fine.

Yahoo just need to find someone who can change the 6 to an 8... Must be tight over there these days. :)

This review is for a previous version of the add-on (3.0.4).