Please Update Rated 3 out of 5 stars

Couldn't install it because it's not compatible with firefox 16.0.1

Updated

You should now be able to install it.