Could be better Rated 4 out of 5 stars

First: update the version number to 1.1a2pre, you are compatible.

Second: you can consider adding {Mozilla/5.0 (Linux; U; Android 2.1) AppleWebKit/530.17 (KHTML, like Gecko) Version/4.0 Mobile Safari/530.17} to user-agent so that web-pages automatically redirected you to mobile version.