Echospacer

About me

Developer Information
Name Echospacer
User since February 13, 2013
Number of add-ons developed 0 add-ons
Average rating of developer's add-ons Not yet rated

My Reviews

YouTube Enhancer Plus

The Best Rated 5 out of 5 stars

I've used this addon for years and it has to be my favourite of all time. If I could give it 10 stars, I would. I love how it saves all my favourite YTube videos in one place as opposed to me having to download them all to my HD. Awesome asson. Thanks

This user has a previous review of this add-on.

LastPass Password Manager

Agreed, version 4. is terrible, but... Rated 3 out of 5 stars

Yeah, the latest version sucks and is riddled with problems and bugs. I (partially) agree with the last review which states be patient and wait for the bugs to be fixed.
However, people have a right to complain and should complain. If people didn't, then no bugs / errors would get fixed and the problem(s) would take the owners much longer to bring a solution.
Being a paid member since day 1, it's frustrating paying for something that doesn't work and informing developers that a new version doesn't work is part of the process.
Until this is fixed, I have reverted back to an earlier version, hence the new rating of 3 stars....which will change to 5 stars again once issues have been fixed :)

This review is for a previous version of the add-on (4.1.49). 

NoSquint Plus

Hurrah! 53 works! Rated 5 out of 5 stars

Excellent news. 53 has fixed the previous issues.
Many thanks for giving us back this fantastic addon.

This review is for a previous version of the add-on (53.0).  This user has a previous review of this add-on.

NoSquint Plus

Reverted back to version 50 Rated 5 out of 5 stars

My fave addon for Firefox. Shame version 52 doesn't work for me.
As others previsouly mentioned, I've now gone back to vers. 50 and all is fine.
Please fix soon.
Best wishes.

This review is for a previous version of the add-on (52.0). 

Theme Font & Size Changer

Rated 5 out of 5 stars

I'll keep it very short and simple. This add-on is FANTASTIC. It's exactly what I needed, since Firefox started messing around with the font sizes etc, in their recent updates.
Updates, lol, now that's often a contradiction in terms....:)

This review is for a previous version of the add-on (7.4.1-signed). 

YouTube Enhancer Plus

The Add-on doesn't work any more Rated 5 out of 5 stars

OK, so this was once good.Over the last few weeks, this isn't working right any more. There is no longer an option to 'add to favourites' when wanting to save your favourite YouTube videos.The only was to now do this is by manually adding them, which sucks because you first have to copy and paste the address-bar into the Options box.I have uninstalled and reinstalled it three times now and it's still the same. Also, where are my 'backups' stored? I'm bored of having to try remember all my saved videos everytime I need to reinstall it.I once gave 5 stars, sadly now, you barely get a 2.Sort it please. Thanks x

UPDATE:
Thanks for the swift response and informing me that the old version was broken and supplying a link to the new version.
It works a treat again. Back to 5 stars. Awesome! *****

This review is for a previous version of the add-on (1.5.1-signed). 

Unshorten.It!

Grinding Halt? - UPDATE... Rated 5 out of 5 stars

Many thanks to the developer for the swift reply to my review.
I am now very happy to say that the add-on is now working perfectly again for some strange reason.

I did not change any settings (again), it just started working, after many hours of doing nothing. Very odd.

Anyway, despite having no idea why it didn't work, I'm very happy that it's back to normal. It's a great add-on.
Keep up the great work. Respect.

This user has a previous review of this add-on.

Unshorten.It!

Grinding Halt? Rated 5 out of 5 stars

This is a great add-on and I've never had any problems with it at all - until today [13-02-2013].
It seems that the add-on has stopped working. I have been trying to use it all day and it just won't work any more. I haven't changed my browsing settings or anything else yet it just doesn't work now.
Is there any known reason for this?
Any help would be greatly appreciated. Thanks.