SmartSnake

About me

Developer Information
Name SmartSnake
User since June 21, 2011
Number of add-ons developed 0 add-ons
Average rating of developer's add-ons Not yet rated

My Reviews

Garmin Communicator

Works with both Firefox 4.0 and 5.0 Rated 4 out of 5 stars

Am presently running Windows 7 (64bit) , Firefox 5.0, and Internet Explorer 9.0

I have the Garmin Communicator plugin 2.93 installed. (Firefox lists it as an extension) Historically, the Garmin Communicator extension has worked problem free with Firefox 4.0 - however, please see my below note. When using Firefox 4 , and connecting to the Garmin web site, my Garmin Nuvi GPS device was instantly recognized; information regarding any available or already installed maps was instantly available.Today is June 21, 2011 Firefox 5.0 was released today. I updated FireFox 5 over the top of Firefox 4 without a problem. When I select the Firefox 5 list of add-ons to check on the status of the Garmin Communicator "plugin" it indicates and shows that Garmin Communicator 2.9.3 is in a disabled status. Firefox 5 also indicates that Garmin Communicator [2.9.3] is incompatible with Firefox 5.0.However, despite what Firefox is indicating, I am having no problems checking for map updates when using Firefox 5.0 ,and my device is instantly recognized by the Garmin server, just as it was when I was using Firefox 4.0I telephoned Garmin technical support and spoke with two of their knowledgeable support technicians who confirmed thatindeed this plugin is working with Firefox 5.0. Regarding the matter of Firefox 5.0 informing me that Garmin Communicator 2.93was disabled and is not compatible with Firefox 5.0, I do not have any explanation why that advisory is appearing; this may be an issue originating on the Firefox side.I have high praise for the Garmin Nuvi support team, my experiences with their knowledgeable support technicians has always been excellent.


-----> NOTE: For those of you who are reporting that a Garmin device is connected and you're still having problems. The Garmin Communicator Plugin Test Page ( http://www8.garmin.com/products/communicator/test/ ) advises "If a Garmin device is connected and you're still having problems, download and install the latest Garmin USB drivers". At one time my Garmin Nuvi device was not being recognized by the Nuvi Server while using Firefox 4.0. However, after following that advice the problem was corrected.

This review is for a previous version of the add-on (2.9.3).