Rated 4 out of 5 stars

I also love this theme. You can make it work with the latest firefox. So far I haven't run into any compatibility problems. I clicked on "View Older Versions". Right click on "add to firefox" and choose save as and save it to your computer. Double click on the xmas-1.1-fx-win.xpi file and it should open in your default archive extraction software. Open the file "install.rdf" with a text editor and change 3.0.* in the line that says: 3.0.*
to 3.5.* or 3.6.* and save the file. Then in firefox go to Tools-Addons-Themes and drag the xmas-1.1-fx-win.xpi into the window. The theme should install. Then restart firefox and hopefully yours works like it did for me.