Not compatible Rated 3 out of 5 stars

says that is compatible until version 6.* but only I can sync until ffx 5.0

This review is for a previous version of the add-on (3.9.10.1-signed). 

Please download from www.xmarks.com -- Mozilla doesn't review updates in a timely manner.