Rated 1 out of 5 stars

This turned to spyware! Someone should report it to Addons site's staff so at least a warning or a full disclosure of what data is being shared is shown to the user before installing the xpi. For those that had previous Foxmarks installed there is no way to know this as its installed automatically by auto-updates, this is a very poor policy and a serious threat to Mozilla auto-update mechanism: we install "Nice extension" v1.0 and let it autoupdate, author turns extension to v2.0 and becomes "Evil Extension", there is nothing user can do to stop the auto-update, there should be addons policy to prevent or at least inform the user of this before aito-update is being applied.

This review is for a previous version of the add-on (3.0.2).